Honda Sc 50Tacho

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Honda Sc 50Tacho

    Hey Leute, es gibt mal was lustiges zu berichten! Normal sollte doch der Tacho der Sc 50 bei 99999tkm stehen bleiben. So hab ich das schon oft gehört und wollte mir eigentlich ein neuen gebrauchten zu legen!
    Nun ist es bei mir der Fall das er wieder von vorne los geht :mad: 8o :D Und ich somit eine Jungfräuliche Honda Sc 50 habe. Schon lustig wenn der tageskilometer Zähler mehr anzeigt als der gesamt!!! =)
  • Das ja cool. Dann gibt es verschiedene Versionen. Also haben die das Problem geloesst bei einigen. Waere spannend was Du fuer ein Modell Baujahr hast im Vergleich zu den anderen wo es nicht funzt. LG, Joe
    scribere non curo ego dolentes quod aliquis fals
  • Ja, aber an dem Bike von einem Kollegen.
    Erst habe ich den Tacho auf 99999 gestellt. Dann eine Runde gefahren und siehe da. Er fängt bei 0 an. Hab Sie dann auf 44000 wieder zurück gestellt. Er hat ein 03 Model wie ich. Das Gerät dafür hat ein Kollege der Motoren instand setzt. Und wo Du Motoren in Neu bekommst mit Einbau. Der hat so ein Gerät. Die Kunden bekommen dann beim Auto irgendetwas im MSG vermerkt. Damit man immer sehen kann was die Karosse runter hat. Und einen Nachweis das der Motor bei x Kilometern getauscht wurde. Man muss den Tacho dafür aber ausbauen und Strom drauf geben.
    Ich warte aber ab bei meiner ob es sich selbst auf 0 stellt. Kein Bock das Ding bei meiner auszubauen. :D ich denke bei den es nicht funktioniert wird das eprom eine Macke haben und die 99999 werden dann nicht überschrieben im eprom. So das es bei 0 anfängt.
    :joint: Fehlende Leistung wird durch Wanhnsinn ersetzt
  • Nicht schlecht, ich hatte damals viele Naechte gebraucht. Programmiergeraet war nie Problem ich habe selber eines dafuer gebaut. Geht auch mit dem aktuellen Microchip Teil. Pic kit geht auch sogar aber nur mit Software Trick. Der Mist war rauszufinden wie die den KM Stand codiert haben so weit ich mich erinnere war das ziemlich uebel gemacht.
    scribere non curo ego dolentes quod aliquis fals
  • LoggoRR schrieb:

    Ja, aber an dem Bike von einem Kollegen.
    Erst habe ich den Tacho auf 99999 gestellt. Dann eine Runde gefahren und siehe da. Er fängt bei 0 an. Hab Sie dann auf 44000 wieder zurück gestellt. Er hat ein 03 Model wie ich. Das Gerät dafür hat ein Kollege der Motoren instand setzt. Und wo Du Motoren in Neu bekommst mit Einbau. Der hat so ein Gerät. Die Kunden bekommen dann beim Auto irgendetwas im MSG vermerkt. Damit man immer sehen kann was die Karosse runter hat. Und einen Nachweis das der Motor bei x Kilometern getauscht wurde. Man muss den Tacho dafür aber ausbauen und Strom drauf geben.
    Ich warte aber ab bei meiner ob es sich selbst auf 0 stellt. Kein Bock das Ding bei meiner auszubauen. :D ich denke bei den es nicht funktioniert wird das eprom eine Macke haben und die 99999 werden dann nicht überschrieben im eprom. So das es bei 0 anfängt.
    Ne es muss verschiedene Versionen geben das EEprom spinnt sicher nicht.
    scribere non curo ego dolentes quod aliquis fals
  • Doch es liegt am eprom. Auf der Platine ist ein Processor. Dieser gibt bei überschreiten der 999999 die Info ans eprom. Diese Adresse im eprom wird aber nicht angesprochen. Da diese Adressierung die vom Processor angesprochen wird nicht gibt oder Fehlerhaft ist. Die checksumme passt nicht. Ich habe mir die Daten des eprom mal angeschaut vor und nach dem ändern. Im Hex den passenden String rausgesucht. Und er ist nach dem ändern anders. Ich bekomme morgen ein Tacho was auch bei 99999 hängst. Ich werde mal die Adressen vergleichen. Man könnte dies durch ein Softwareupdate ändern. Das ist aber bei den Tachos nicht vorgesehen . Deswegen gibt es auch seitens Honda keins. Wenn das Eprom Hersteller ist ST auf dem Tacho. Die checksumme nicht stimmt wird dort auch nichts überschrieben und Du hängst in einer Schleife. Ich werde es testen.

    Hier passt im eprom die Prüfsumme nicht zur Adresse 0Ex00000100. Bei dem Tacho von vorhin passt Sie und der String im Hex ändert sich.
    :joint: Fehlende Leistung wird durch Wanhnsinn ersetzt

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von LoggoRR ()

  • Ja aber ob das ein Fehler ist oder womoeglich Absicht ist nun fraglich.
    Also gibt es evtl verschiedene EEproms je nach Land und Baujahr. Oder verschiedene software im Chip. Ich schliesse komplett aus das das EEprom schadhaft ist das waere absolut unmoeglich. Ich entwickle hard und software sowas waere fuer mich komlett abstrus.
    scribere non curo ego dolentes quod aliquis fals
  • Ein EEPROM ist ja so weit dumm, das ist ja nur ein Speicher, entweder wurde vor dem Einbau in den Tacho schon was rein geschrieben was der Controller dann nur liest, oder der Controller schreibt was rein und liest es wieder.
    Der Controller ließt ja entweder nur von der Adresse die er anspricht, oder schreibt was rein. z.B. den Kilometerstand an eine oder mehrere Adressen.
    Eine sogenannte Prüfsumme wird von der Software erzeugt, das EEPROM generiert so was nicht selber, wenn die drin steht, schreibt das auch der Controller in eine bestimmte Speicheradresse.
    Grüße aus dem Altmühltal, Chris :biker:
  • FireBlade Chris schrieb:

    Ein EEPROM ist ja so weit dumm, das ist ja nur ein Speicher, entweder wurde vor dem Einbau in den Tacho schon was rein geschrieben was der Controller dann nur liest, oder der Controller schreibt was rein und liest es wieder.
    Der Controller ließt ja entweder nur von der Adresse die er anspricht, oder schreibt was rein. z.B. den Kilometerstand an eine oder mehrere Adressen.
    Eine sogenannte Prüfsumme wird von der Software erzeugt, das EEPROM generiert so was nicht selber, wenn die drin steht, schreibt das auch der Controller in eine bestimmte Speicheradresse.
    Genau so ist das. Und kaputt gehen die niemals also das ist dann schon extreme Ausnahme. Und wenn der Controller eine Adresse anspricht die nicht existiert, das ist auch sehr suspekt aber kan alles sein. Ich weiss, nur Sachen die man selber gebaut hat kann man auch vertrauen.
    scribere non curo ego dolentes quod aliquis fals
  • So war es gemeint Chris. Nur blöd geschrieben. Die Karre vom Kollegen ist ein Deutsches Model. Was ich vorhin gehört habe vom Kollegen mit der Motoreninstandsetzung, er macht nur was er vertreten kann. Würde sonst nie an einem Tacho rumschrauben um zu bescheissen. Das bei manchen Motorrädern das eprom ausgelesen wird. Dann ein neues eingelötet und die Sicherung wieder eingespielt wird. Warum sollte man das tauschen wenn es nicht kaputt ist. Und dann mit der Sicherung vom
    Alten wieder beschreiben. Ich wußte auch garnicht das er so ein Teil hat. Haben vorhin nur was abgegeben und sind darüber ins Gespräch gekommen.
    :joint: Fehlende Leistung wird durch Wanhnsinn ersetzt